CHM File does not show its content
Symptoms
Due to recent customer reports, the RFC Connector Help File (available for download here) may not display its contents correctly if it was downloaded from our website using Internet Explorer. Typical symptoms of this problem are:
- A popup window appears when the CHM file is opened, containing a warning about possibly insecure content
- In the Help Viewer, only the structure of the help file is displayed on the left, but the pages on the right are replaced by an Internet Explorer error page („This page cannot be displayed“)
Cause
This problem is caused by Microsoft‘s Security Update 896358, which patches a security vulnerability in HTML Help.
Solution
To be able to view the content of the RFC Connector help file, it may be necessary to unlock the HTML Help file before viewing it. To do so, just right-click the file on the file system, choose „Properties“ and press the button marked „Enable access“ in the Properties dialog. Additional information may be found in the Microsoft Knowledgebase entry 902225.
It has also been reported that even if the aforementioned step is taken, the file may not be viewable if located on a network share. In this case, it may be necessary to copy the file to the local harddisk before it can be viewed properly.